ЗНАЙОМСТВО З MICROSOFT OFFICE

:: Меню ::

Головна
 
Книга для гостей
   
Контакти
Добавити у вибране

:: Завантаження ::

eda9e0fa

:: Лічильники ::

= =

 

 

 

 

Вправа 4. Копіювання формул

Іноді потрібно провести однакові розрахунки з різними групами осередків. У такій ситуації можна заощадити час і скопіювати формули, оскільки Excel підтримує відносну адресацію осередків. У рядку 10 нашого прикладу вже є формули, що розраховують відносний приріст продажів по місяцях для клієнта Фантом. Давайте скопіюємо їх, щоб отримати таблицю приросту продажів для всіх клієнтів.

  1.  Клацніть на будь-якому непорожньому осередку в рядку 10. Ви побачите, що вибрана формула посилається на осередки рядка 2.

  2.  Виділите діапазон B10:f10.

  3.  Натисненням клавіш Ctrl+c скопіюйте осередки.

  4. Клацніть на осередку В11, а потім на кнопці Вставити панелі інструментів Стандартна. З'явиться ще один рядок осередків з формулами. Клацніть на будь-якій з них і погляньте в рядок формул. Ви побачите, що формули нових осередків посилаються на дані рядки 3, як показано на мал. 10.9.

  5.  Клацніть на осередку В 12 і натисніть клавіші Ctrl+v, щоб вставити ще один рядок. Формули цього рядка вже посилатимуться на дані рядки 4. Таким чином, номери осередків даних змінюються рівно на стільки кліток, на скільки зміщується формула, що вставляється.

Мал. 10.9. Копіювання формул

Примітка

Звернете увагу, що вирізування осередків з формулами з подальшою їх вставкою в інше місце листа ніяк не змінює посилання на дані.

  1.  Вставте той же самий фрагмент в осередки В13 і В14.

  2.  Скопіюйте заголовки рядків з осередків А2:а6 в осередки А10:а14.

Примітка

Зазвичай Excel формує відносні посилання на осередки. Але іноді потрібно послатися у формулі на клітку з константою, яка не повинна мінятися при копіюванні формули в інший осередок або при переміщенні початкових даних. В цьому випадку користуйтеся абсолютними посиланнями, які відрізняються від відносних наявністю символу $ перед буквою стовпця, номером рядка або перед обома цими характеристиками, наприклад $Е$15. У такому посиланні не змінюється та частина, перед якою коштує знак $. Наприклад, копіюючи формулу =СУММ($В$2:$0$6) (=SUM($B$2:$G$6)) у інший осередок, ви отримаєте той же самий результат, що і в початковій клітці формули.

Операція підсумовування рядків або стовпців — одна з найбільш поширених. Щоб створити формули сум рядків або стовпців, не потрібно навіть копіювати осередку, Excel пропонує ще швидший спосіб.

  1.  Виділите групу осередків 12:16.

  2. Клацніть на кнопці Автосума (Autosum) панелі інструментів Стандартна.

  3. Залишилося тільки ввести в осередок II заголовок Разом, і стовпець загальної суми продажів для всіх п'яти клієнтів готовий (мал. 10.10).

Примітка  

Звернете увагу на значок вставки, що з'являється в правому нижньому кутку вставленого фрагмента. Завдяки ньому легко вибрати варіант вставки — чи хочете ви вставити число з копійованого осередку або абсолютне або відносне посилання, чи потрібно зберігати формат початкового осередку і так далі


:: Наша кнопка ::

Отримати код:

Підтримайте наш сайт і розмістіть нашу кнопку на своєму ресурсі.


:: Реклама ::


:: Посилання ::

|


 

 

 


Copyright © Yandux.biz, 2017